求一道C++编程题

Description:
自然数中,完数寥若晨星,请在从1到某个整数范围中打印出所有的完数来。所谓“完数”是指一个数恰好等于它的所有不同因子之和。例如,6是完数,因为6=1+2+3。而24不是完数,因为24≠1+2+3+4+6+8+12=36。

Input:
输入数据中含有一些整数n(1<n<10000)。
Output:
对于每个整数n,输出所有不大于n的完数。每个整数n的输出由n引导,跟上冒号,然后是由空格开道的一个个完数,每个n的完数列表应占独立的一行。
Sample Input:
100
5000
Sample Output:
100: 6 28
5000: 6 28 496

#include<stdio.h>
#include<math.h>
int factor(int m)
{
int i,s=0;
int n;
int j,r;
n =m;
for(i=2;i<n; i++){
r = 0;
for(j=1;j<i;j++){
if(i%j == 0){
r = r + j;
}
}
if(r == i){
printf("the result is:%d\n",r);
s++;
}
}
return s;
}
void main()
{
int i,m,sum;
m = 10000;
sum = factor (m);
printf("the total is:%d\n",sum);
}
温馨提示:内容为网友见解,仅供参考
第1个回答  2011-05-10
#include<iostream>
#include<math.h>
using namespace std;
void main()
{
int n,j;
cout<<"Input:"<<endl;
cin>>n;
if(n<1||n>10000)
cout<<"Error!"<<endl;
else
{
cout<<"Output:"<<endl;
cout<<n<<":";
for(int i=2;i<n;i++)
{
int r = 0;
for(j=1;j<i;j++)
{
if(i%j == 0)
r = r + j;
}
if(j==r)
cout<<" "<<j;
}
}
cout<<"\n";
}
相似回答