一道c++编程题,求出e的值

求出e的值

时间限制: 1000 ms 内存限制: 65536 KB
提交数: 1829 通过数: 823
【题目描述】
利用公式e=1+11!+12!+13!+...+1n!e=1+11!+12!+13!+...+1n! ,求e的值,要求保留小数点后10位。

【输入】
输入只有一行,该行包含一个整数n(2≤n≤15),表示计算e时累加到1n!1n!。

【输出】
输出只有一行,该行包含计算出来的e的值,要求打印小数点后10位。

【输入样例】
10
【输出样例】
2.7182818011

#include <stdio.h>
#include <math.h>

int main() {
    double e=1.0f;
    int n, i=1;
    long f=1;
    printf("Input n:");
    scanf("%d", &n);

    while (i<=n) {
        e += 1.0/f;
        f*=++i;
    }
    printf("%.10f", e);
}

温馨提示:内容为网友见解,仅供参考
第1个回答  2018-05-18
#include <stdio.h>#include <math.h> int main() { double e=1.0f; int n, i=1; long f=1; printf("Input n:"); scanf("%d", &n); while (i<=n) { e += 1.0/f; f*=++i; } printf("%.10f", e);}

一道c++编程题,求出e的值
include <stdio.h>#include <math.h>int main() { double e=1.0f; int n, i=1; long f=1; printf("Input n:"); scanf("%d", &n); while (i<=n) { e += 1.0\/f; f*=++i; } printf("%.10f", e);} ...

C++中求出e值
你的求e值的C++程序,我帮你改完了,你看看吧(改动的地方见注释)include<cstdio>using namespace std;int main(){ int x,y,z,a=1;\/\/这里把x定义成整型 double sum=0; scanf("%d",&x);\/\/这里把scanf("%lf",&x);改成scanf("%d",&x); for(y=1;y<=x;++y) { a=1;\/\/这里...

C++ 编程问题、求大神解答
第一题:#include<iostream> include<cstdlib> using namespace std;int main(){ double a,b,c,s,v;cout<<"请输入立方体的三条边长,用空格隔开,按ENTER键结束输入:";cin>>a>>b>>c;s=2*(a*b+a*c+b*c);v=a*b*c;cout<<"立方体的三条边为:a="<<a<<" "<<"b="<<b<<" ...

编写c++源程序计算e=1+1\/1!+1\/2!+1\/3!+...+1\/n!+...计算e的值,直到1\/...
求和的部分自然也需要用到累加器:int e=0;然后for(int i=1;true;i++)e=1\/y(i)假设y就是封装的子函数 然后再循环体中加入判断条件break一下跳出循环即可;最后用printf打印出来就可以了。这题本来就用面向过程的方法就能解决,而且还要求用printf打印出来,完全没必要用c++ 用c语言就可以了。

C++求e的近似值
include "stdafx.h"#include<iostream>using namespace std;void main(){int a, i;float y=0;for (i = 1; i <= 100; i++){a=1;for(int j=2;j<=i;j++)a *= j;y += 1.0\/a;if(1.0\/a < 0.000001)break;}cout << "e=" << y+1<< endl;} 请采纳 ...

悬赏100分,求做一个C++编程题,在线急等!高手来做
悬赏100分,求做一个C++编程题,在线急等!高手来做 1:有一篇英文文章存储在文件a.txt中,编个c++\/c程序将其中的单词word1替换为word2(替换和被替换单词都由键盘输入)2:需按照区分和不区分大小写两种情况讨论和编写。3:尽量不使用高... 1:有一篇英文文章存储在文件a.txt中,编个c++\/c 程序将其中的单词word...

求解一道c++编程题
void print(int* p, int n);int main(){ int arr1[10] = {1,2,3,4,5,6,7,8,9,10};int arr2[] = { 0 };int count = search(arr1, 10, arr2);print(arr1, 10);print(arr2, count);system("pause");} int search(int* p1, int n, int* p2){ int result = 0;...

用c++求e的x次方,根据公式计算数值ex = 1 + x\/1! + x2\/2! + x3\/3...
cout<<"e的"<<x<<"次方是:"<<result<<endl;system("pause"); \/\/为了使你生成的EXE文件执行后能够暂停下来 return 0;} long factorial (int n ) \/\/ 外部函数,用来计算阶乘的 { long fact=1;for (int i=1;i<=n;i++)fact*=i;return fact;} VS 6.0下编译通过。。看懂方法就可以...

。。。看下这个求e近似值的c++程序,哪里错了
for(a=1;1.0\/fac(a)<=10e-6;a++)改为 for(a=1;1.0\/fac(a)>=10e-6;a++)另外,泰勒级数展开少加了1。include <iostram> using namespace std;void main(){ double fac(int);int a;double e=1,b;for(a=1;1.0\/fac(a)>=10e-6;a++){b=1.0\/fac(a);e=e+b;} cout...

关于C++的一道编程题,请高手帮忙阿
cout << "Valid commands are: b(egin) c(hange) d(el) e(nd) f(ind) g(o) h(elp)" << endl << " i(nsert) l(ength) n(ext) p(rior) q(uit) w(rite)" <<endl; while(buffer.get_command()) buffer.run_command(); return 0;}我做的数据结构作业,没有文件功能,改一下就可以了...

相似回答